Document templates should be added to SharePortals by administrators with appropriate SharePoint permissions to modify and add to the site.

However, you may find that even with these permissions, you receive an error when uploading a new document template to SharePoint. The error will indicate you either require access or don’t have permission to perform the action.

There is a per-site SharePoint setting which prevents this behaviour by default, called DenyAddAndCustomizePages. It can be changed on a SharePoint site using the SharePoint Online Management Shell. Connect to the site on the command line and run the following command:

Get-SPOSite https://your-sharepoint-domain-and-site | fl

This will show whether the DenyAddAndCustomizePages feature is enabled or not on your site. If it is enabled, disable it by running the following command:

Set-SPOSite https://your-sharepoint-domain-and-site -DenyAddAndCustomizePages 0

Once this is done, you can run:

Get-SPOSite https://your-sharepoint-domain-and-site | fl

And it should show that DenyAddAndCustomizePages is now disabled. This should allow you to now return to the previous step and upload the new document template.

Feedback

Thanks for your feedback.

Post your comment on this topic.

Please do not use this for support questions.
www.shareportals.co.uk

Post Comment